Showing results for 
Show  only  | Search instead for 
Did you mean: 
Message 621 of 1,143

Re: McSvHost.exe causes error on Shutdown

Nisa please post the error log part and I will get a mcafee bod to comment

Unsure re the registry bit will look at mine

Former Member
Message 622 of 1,143

Re: McSvHost.exe causes error on Shutdown

In the wake of this shutdown error:  does anyone know how to safely delete all traces of McAfee from the registry (considering that MCPR.exe has been run and doesn't clean the registry out)? If that can't be done, I would be happy just to know how to look for the McAfee traces in the registry, even if I can't remove them safely. Any suggestions? Don't want to have to resort to technical support - next to impossible to communicate with them.

Contributor III
Message 623 of 1,143

Re: McSvHost.exe causes error on Shutdown

Application Hang

Fault Bucket 1180947459.

all I can see on the description is Application Error

Faulting application McSvHost.exe, version, faulting module McSvHost.exe, version, fault address 0x0001efe2.

MCSCAN32 Engine Initialisation failed. Engine returned error : 1

Message was edited by: Nisa51 on 12/05/10 02:22:11 CDT

It wont let me say the last word, Bu     ck     et

Message was edited by: Nisa51 on 12/05/10 02:23:20 CDT
Message 624 of 1,143

Re: McSvHost.exe causes error on Shutdown

As regards Cburrows post about getting rid of ALL mcafee software, then reinstalling fresh mcafee, seems to have fixed his/her issue.

However, on my netbook I did a "COMPLETE" reinstall of windows, using the acer "E-Recovery" application thats loaded on most acer netbooks from new, which formats the hard drive, and reinstalls windows/drivers back to factory settings.

This in my eyes SHOULD remove ALL old traces of mcafee products (2009) in my case.

I then did a fresh install of mcafee 2010 from my mcafee account, only to find the error returned after a few days.

So in my opinion, Cburrows's fix might just be luck.

As on my netbook (nothings changed recently) but went for 5-6 days without the error, then it returned, now happenings every shutdown.


Message 625 of 1,143

Re: McSvHost.exe causes error on Shutdown

Thanks probably another issue but in case of use passed it on. Re editing remaining bits out of the registry I'd rather pass on saying how as if you do not know and keep your wits about you you can make a mess. I also refrain from using registry cleaners (my preference)

Mezzy yes I have seen that also that is why I was sceptical re issue being fixed but remember my daughters PC is clean as is my PC I setup last week. So it is possible so best to wait and see if CB won the lotto....

Message was edited by: Peacekeeper on 12/05/10 7:27:45 PM
Message 626 of 1,143

Re: McSvHost.exe causes error on Shutdown

I removed all the McAfee stuff via Control Panel.  Then I downloaded MCPR and ran that.  Finally I re-installed the McAfee stuff from my Account page.

This got rid of the message on startup telling me that the Backup/Restore program had been uninstalled but it did not eliminate the error on shutdown.

Message 627 of 1,143

Re: McSvHost.exe causes error on Shutdown

I have also run "Windows Live One Care Safety Scanner" and it returns two registry errors it can’t fix:-



Seems strange…! 

A few days ago it only found the first of these..!

Contributor III
Message 628 of 1,143

Re: McSvHost.exe causes error on Shutdown

Hi Peacemaker,

Those Items were discovered using Malewarebutes, not a registry cleaner? Malwarebytes quarantined them as malware

Contributor III
Message 629 of 1,143

Re: McSvHost.exe causes error on Shutdown

Oh wait my Post 695 re reading the Malwarebytes that must be windows antivirus and not McAfee, I think sorry

McAfee Employee
McAfee Employee
Message 630 of 1,143

Re: McSvHost.exe causes error on Shutdown

When this problem first came to our attention, we identified the cause and released a fix for that in April.  However, since it obviously didn't resolve the issue for everyone, we have gone back to the drawing board and have since realized that this issue has multiple causes.

A major problem with diagnosing this issue has been that it does not occur on every XP system.  For example, I run our products on different fully-patched XP systems and I have yet to see it happen.  We've tried reproducing it (as Peacekeeper and several of our developers and technicians have) on multiple XP machines and so far we cannot force the problem to occur, so we've had problems getting a problematic machine to run process scanning tools (like process explorer) and other diagnostic tools.

We've since collected logs from several systems with the problem (some from people in this thread) and believe we have found another cause and are working on that.

Also, as of this month, this issue has gained some high profile attention, mostly due to this thread.  Specifically, it's been pushed to the developers and more importantly, the decision makers.

I'll update this thread when I hear what progress is being made.

How Many Badges Can You Collect?
Ready for a little competition? Members like you are earning badges and unlocking perks for their helpful answers. Are you? Click here to find out.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community