×

Who Me Too'd this topic

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Who Me Too'd this topic

IainStrachan
Contributor

Locate my device not working on mcafeemobilesecurity website

I cannot get the Locate My Device feature to work when on the mcafeemobilesecurity website.

 

When I log in to this site it shows on the map the location of my device two years ago, and if I click "locate" it times out.

 

However if I visit the same website _from the device itself_ it shows the current location.  That's no use at all if I've lost the phone!

So I rang customer support, who got me to try it with three different browsers (Firefox, Internet Explorer and Chrome) and all behaved the same way.

Only after a while he admitted that he had just tried to locate his own device with the mcafeemobilesecurity  website and it didn't work either!

He directed me to home.mcafee.com and it did show the correct location.

 

However, if you Google Mcafee find my phone it goes to the mcafeemobilesecurity website, and DOES NOT WORK.

 

Does anyone else have this problem and when are Mcafee going to fix it?

Who Me Too'd this topic

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community