cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
akos
Level 7
Report Inappropriate Content
Message 1 of 8

webadvisor not in firefox add-ons

 
7 Replies
siddharth_r
McAfee Retired
McAfee Retired
Report Inappropriate Content
Message 2 of 8

Re: webadvisor not in firefox add-ons

Hi @akos 

Please follow the below steps to enable webadvisor extension in firefox. If you still face any issue help us with firefox version and webadvisor version installed on your machine.

  • Open Firefox.
  • Click the stacked menu icon on the right.
  • Select Add-ons.
  • Click Enable next to McAfee WebAdvisor 

Re: webadvisor not in firefox add-ons

I followed directions but when I click on add-ons under Firefox I do not see Web Advisor listed and did not find it when I searched for it.

I have Firefox Version 74.0.1 which was updated on Friday. That is when Web Advisor icon disappeared from my toolbar and the green "safe" check mark diasapeared from searches.

Re: webadvisor not in firefox add-ons

Is it showing in Control panel Programs and features?

 

Re: webadvisor not in firefox add-ons

Yes, it is there. My McAfee LiveSafe software shows under Security that WebAdvisor is on. I had this problem 2 years ago and had to go through a technician to get it fixed.

I guess McAfee and Firefox don't coordinate.

Thanks.

Re: webadvisor not in firefox add-ons

I Firefox does work fine with Webadvisor it is on my PC and others of the family .

If it will not show up the next best thing is to remove WA via the control panel and reinstall it via www.siteadvisor.com

Good luck

Re: webadvisor not in firefox add-ons

I tried that. Deleted WA and then reinstalled. Didn't work In fact, WA does not show up in Programs and Features either.

Spent two hours with McAfee techs (3 of them) and they couldn't solve the problem.

Thanks for suggestion though.

Re: webadvisor not in firefox add-ons

This getting queer. When you uninstalled WA can you install it from the McAfee interface in the tools options ie the gear symbol? Also as of how it is now is WA showing as on in this area.

It sounds as if another uninstall and reinstall of Mcafee itself as per

How to remove McAfee

and running the preinstall tool as well prior to the reinstall might help. That and maybe Firefox reinstall. I would have assumed the techs would have tried that as it is a common 1st fix they try.

Preinstall Tool

In the long time using WA I have never had a FF issue strange good luck.

Oh did the tech escalate the issue to a higher tech level?

 

How Many Badges Can You Collect?
Ready for a little competition? Members like you are earning badges and unlocking perks for their helpful answers. Are you? Click here to find out.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community