cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Weird problem using Siteadvisor in Firefox

i noticed today that Siteadvisor is behaving strange when i using Firefox when i want a report on a site i can't get it i'm coming to this site everytime:

http://www.siteadvisor.com/sites/google.se?version=2&core_ver=1.0&pip=true&premium=false&client_ver=...

the only thing with is changing with the link is the sitename i want more information about

and why it says IE plugin?

i have always use the exe version and that has always worked fine but not now

i have tried to use the Firefox plugin but the same thing happens

i use Norton 360 can it have something to do with that? Siteadvisor it allow there so that is not the problem

please can someone help me with this it's driving me nuts
1 Reply

Is there someon who can help me

is there someone who's know what the problem is?
How Many Badges Can You Collect?
Ready for a little competition? Members like you are earning badges and unlocking perks for their helpful answers. Are you? Click here to find out.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community