cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Mercury7
Level 9
Report Inappropriate Content
Message 1 of 20

Unable to get latest version of WebAdvisor working - even after several uninstalls/installs

Jump to solution

I have WebAdvisor installed on 3 computers, each running IE-11 and each fully updated to the latest set of Windows Updates as of 10/28/2016:

  Computer A - Windows 7, WebAdvisor 4.0.9.136

  Computer B - Windows 7, WebAdvisor 4.0.4.164

  Computer C - Windows 10, WebAdvisor 4.0.4.164

I've used WebAdvisor, and previously SiteAdvisor, for several years and found it to be a very useful tool.  In looking at the installation dates, I believe 4.0.4.164 to be a later version than 4.0.9.136.

On Computer A, WebAdvisor works as it should by returning green/red indicators adjacent to search results (Google).

  There are 2 entries found in the gear icon, each with an adjacent McAfee icon:  "McAfee WebAdvisor ..." and "View Site Report ...".  This is as it should be (or at least has been for quite some time).

  However, IE doesn't show any items under the Manage Add-on results.  Is this a problem?

   In the "About" screen, under the "Search Results" settings there are 3 choices ("Tell me if a search result is safe only in Safe Search", "Tell me if a search result is safe in any search engine", and "Don't tell me about search results".  This is as it should be (or at least has been for quite some time).

On Computer B, WebAdvisor does NOT show any green/red indicators adjacent to the search results (Google)

  There is only one entry in the gear icon, and it does not have an adjacent McAfee icon:  "McAfee Web Advisor"

  Under the Manage Add-on results, there is one entry:  McAfee WebAdvisor BHO

  In the "About" screen, there are NO "Search Results" settings to choose from - even the text "Search Results" is no longer there.

On Computer C,  WebAdvisor does NOT show any green/red indicators adjacent to the search results (Google)

There is only one entry in the gear icon, and it does not have an adjacent McAfee icon:  "McAfee Web Advisor"

Under the Manage Add-on results, there is one entry:  McAfee WebAdvisor BHO

In the "About" screen, there are NO "Search Results" settings to choose from - even the text "Search Results" is no longer there.

So both Computer B (Window 7) and Computer C (Windows 10) seem to have the same problems - and they are on WebAdvisor 4.0.4.164.

What I've done is to concentrate my investigation on Computer B.  I have done the following (with several restarts along the way):

  Downloaded and installed WebAdvisor over the top of the existing installation - nothing changed.

  Via Control Panel, uninstalled WebAdvisor and reinstalled it - nothing changed.

  Via Rev0, uninstalled WebAdvisor, used the "Moderate" cleanup to remove a number of leftover registry entries and files/folders, and reinstalled WebAdvisor - nothing changed.

I'm stumped.  I tend to think something is wrong with version 4.0.4.164.

I would appreciate any insight or suggestions you all might have.

1 Solution

Accepted Solutions
dougk_t3
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 11 of 20

Re: Unable to get latest version of WebAdvisor working - even after several uninstalls/installs

Jump to solution

Thanks Cliff.

Mercury7,

Yes, there were several functions in WebAdvisor that were removed for the IE add-on, at the behest of Microsoft.  We documented these changes in this FAQ  - https://service.mcafee.com/webcenter/portal/cp/home/articleview?locale=en-US&articleId=TS102584

View solution in original post

19 Replies
catdaddy
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 2 of 20

Re: Unable to get latest version of WebAdvisor working - even after several uninstalls/installs

Jump to solution

​,

                     I would choose the setting ( "Tell me if a search result is safe in any search engine") in Internet Explorer 11 in order to affirm you receive 'Rating' annotations in your searches. As for McAfee Web Advisor (not) being displayed in your 'Manage Add-ons' section, this is normal.

                     Have you attempted to contact Technical Support and seek their advice?

                      https://service.mcafee.com/webcenter/portal/cp/home/contact

Regards,

CD

Cliff
McAfee Volunteer
Mercury7
Level 9
Report Inappropriate Content
Message 3 of 20

Re: Unable to get latest version of WebAdvisor working - even after several uninstalls/installs

Jump to solution

I am unable to "choose a setting" because there are no settings displayed to choose from (on Computers B and C).

I'll try contacting Technical Support this next week ... and I will report back with the results.

Thanks.

catdaddy
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 4 of 20

Re: Unable to get latest version of WebAdvisor working - even after several uninstalls/installs

Jump to solution

Thank you   I would like to inform you that I have in addition brought this up as a 'Topic of Discussion' on Monday's Conference Call.

Cliff
McAfee Volunteer
Mercury7
Level 9
Report Inappropriate Content
Message 5 of 20

Re: Unable to get latest version of WebAdvisor working - even after several uninstalls/installs

Jump to solution

Thanks for the quick response, CD.

FYI - a year ago I initiated a discussion concerning version numbers: 

The responses were very informative.

Based on that, I'm pretty sure that version 4.0.4.164 (Computers B and C - which have the problems) is newer than version 4.0.9.136 (Computer A - which does not have the problem).

songbird
Level 7
Report Inappropriate Content
Message 6 of 20

Re: Unable to get latest version of WebAdvisor working - even after several uninstalls/installs

Jump to solution

Hi I am also getting the same problem in google chrome , i use to show me all the safe site when i did my search now am also getting nothing at all, i have removed it , re installed it , cleared everything off my laptop and site it wont work at all, this only started to happened saturday/sunday and all off a sudden i started to get pop ups which i have never had, i dont have any viruses , run numeris  scans etc everything is up to date but my site/webadvisor is no longer work

Mercury7
Level 9
Report Inappropriate Content
Message 7 of 20

Re: Unable to get latest version of WebAdvisor working - even after several uninstalls/installs

Jump to solution

Per catdaddy's suggestion I contacted technical support.  I ran the McAfee Virtual Technician (MVT) tool (which found some problems which I won't go into unless someone is really interested) and held a Chat session.

The bottom line is that with the latest version of IE, there are now limitations in the way that browser extensions (including WebAdvisor) are allowed to integrate with IE.  "Because of these changes some functionality has been removed in the Internet Explorer version of McAfee WebAdvisor as of version 4.0.4."

Here are the changes:

1.  "McAfee webadvisor wont show any website ratings on the new version of IE only."

2.  "Password reuse warnings are no longer displayed. Previously, McAfee WebAdvisor would warn you when you had used the same password on two or more different websites."

3.  "SecureSearch prompts are no longer displayed. Previously, McAfee WebAdvisor would periodically prompt you to change to SecureSearch via the Yahoo! search engine if it detected that this option was not enabled."

4.  "Annotations are no longer available. Previously annotations would provide you with a green, yellow, or red site rating beside each search result. However, if you accidentally surf to a site that McAfee WebAdvisor considers dangerous, you will still be directed to a warning 'block' page."

Per technical support:  "Our development team is currently working on this issue and this will be addressed in the next updated version released."

Also per technical support:  "I would suggest that you use Google Chrome or Mozilla Firefox for experiencing a safe browsing."

catdaddy - I'd be interested in knowing if your conference call confirms the above or not.

Mercury7

catdaddy
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 8 of 20

Re: Unable to get latest version of WebAdvisor working - even after several uninstalls/installs

Jump to solution

​,

            I will bring your latest correspondence up in about an hour. FYI, I utilize Internet explorer 11 as my (Default) Browser. My current version is (4.0.3.279) and all is functioning perfectly? I will get back to you following todays Call.

Sincerely,

Cliff

Cliff
McAfee Volunteer
catdaddy
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 9 of 20

Re: Unable to get latest version of WebAdvisor working - even after several uninstalls/installs

Jump to solution

During the interim....

​ Could you kindly add to the discussion?

Thank you,

Cliff/CD

Cliff
McAfee Volunteer
catdaddy
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 10 of 20

Re: Unable to get latest version of WebAdvisor working - even after several uninstalls/installs

Jump to solution

​,

                     I apologize for my delayed response. We did indeed discuss this on the Conference call. And yes it was mentioned that there are some changes being made in regards to 'Internet Explorer 11', due to Microsoft seemingly being more like Windows 10 (Edge) in the manner of how the Browser handles 'Add-ons'\Extentions' and so on.

                    As I stated earlier in this thread, I am currently running the latest Version\Build ( 11.0.36 ) - KB3191492 ( On a Windows 7 Sp1 machine). My experience is that it still functions as always? Hopefully when a Senior Level Engineer gets to feeling better, he will add to the discussion.

Regards,

Cliff\CD

Cliff
McAfee Volunteer
How Many Badges Can You Collect?
Ready for a little competition? Members like you are earning badges and unlocking perks for their helpful answers. Are you? Click here to find out.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community