cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
relativity
Level 7
Report Inappropriate Content
Message 1 of 20

Site advisor -Not working in latest Chrome 35.0

Jump to solution

i feel like i am getting the run around from Mcaffee tech support ..

My Siteadvisor stopped working in chrome a few weeks back and they(suuport) tell me it's because of a problem with the plugin for Chrome

yet

i find no other users here or via Google complaining about this same issue .. and i can't believe i am the only one

Site advisor works for me in my IE and i t works in my FF browser but not in my Chrome browser ..

Is anyone else having this issue too ? ?

i am running windows 7 home and using Mcaffe Internet Security . .my chrome is the latest up to date version.

Thanks if you can help please.

1 Solution

Accepted Solutions
Hayton
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 15 of 20

Re: Site advisor -Not working in latest Chrome 35.0

Jump to solution

relativity wrote:

That is the reason why i was trying to drag the .crx file to that page.

As I said, that won't work. It's one of the things I tried.

Chrome can be complicated sometimes, and I'm not entirely certain that I recall exactly the sequence of actions that were necessary to get SA working again.

First, the question of synching. If you've synched Chrome then you will find that the synched Chrome list of extensions (without SiteAdvisor) gets re-applied. Let me know if that happens, I'm sure I found something buried in the Chrome FAQs or Latest Issue list about that.

The first step is to uninstall SiteAdvisor completely, but before you do click the wrench symbol in Chrome and select Tools-->Clear Browsing Data. Make sure all the boxes are checked and applied From the Beginning of Time. This will remove all cookies and plug-in data.

Go to 'Programs & Features' and find the entry for McAfee (not MVT). There is no separate entry for SiteAdvisor. Click to uninstall and it will ask if you want to remove everything or just SiteAdvisor. Agree to remove SiteAdvisor.

Then you have to re-install SiteAdvisor from the McAfee site - go to

https://www.siteadvisor.com/download/windows.html

and scroll right down to the bottom of the page to get the free version.

You may need to reboot so that SiteAdvisor can check to make sure it's got the latest version, and download it if you haven't.

Then restart Chrome and check in Task Manager to see if McChHost is running. If it is, you're part way there. If not, it means I have to dig around in the Chrome forums and various Help sections to see what it was I found before that helped me get SA back. I have a nasty feeling that my installation of Chrome was corrupted and had to be deleted & re-installed. I hope that's not the case here.

Message was edited by: Hayton on 22/06/14 23:48:57 IST

View solution in original post

19 Replies
k3tg
Level 14
Report Inappropriate Content
Message 2 of 20

Re: Site advisor -Not working in latest Chrome 35.0

Jump to solution

Please post the version of Site Advisor you are using?             My version is 3.6.6.129

Re: Site advisor -Not working in latest Chrome 35.0

Jump to solution

It works in  mine OK in Chrome 35, mind you I had to disabled/enable to get it to show in the address bar a few minutes ago.

Did you ask Technical Support to escalate the case?

Hayton
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 4 of 20

Re: Site advisor -Not working in latest Chrome 35.0

Jump to solution

I moved this from Service & Support to the SiteAdvisor section as a more appropriate place for the thread.

There have in fact been many reports of problems with SiteAdvisor not working properly, or working intermittently, in Chrome, going back at least a couple of months. This is because of a change to the way SiteAdvisor has to operate in the browser, forced by Google's decision not to allow third-party extensions. I see these problems myself, and have not yet found a reliable way to persuade SiteAdvisor to run perfectly in Chrome. It works, after a fashion, but there's usually a period after Chrome starts when SA is inactive. Even after SA starts it may have difficulty communicating with the SA servers, so that the icon remains grey for all sites for a further period. Then somethnig clicks and it begins to work properly.

So, we need to know what are the observed symptoms in this case.

relativity
Level 7
Report Inappropriate Content
Message 5 of 20

Re: Site advisor -Not working in latest Chrome 35.0

Jump to solution

i have twice been with them online .. both times they told me it was an issue with the plugn and Chrome 35.
So in a way you are confirming my thoughts after Google search and finding no other users complaining of same problem.
i am not clear exactly how to escalet a case .. how di dyou enable/disable ..

i do not see the Mcafee extension/plugin for siteadvsior listed in my Chrome's extensions ..

Thanks

relativity
Level 7
Report Inappropriate Content
Message 6 of 20

Re: Site advisor -Not working in latest Chrome 35.0

Jump to solution

i looked in the MCChost file ? ? is that correct for the version info .. it says 3.6.5.118
Is that the correct place to determine the veriosn number ?

Hayton
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 7 of 20

Re: Site advisor -Not working in latest Chrome 35.0

Jump to solution

SiteAdvisor in IE and FF is running under McSvHost; in Chrome SA runs as a separate process, McChHost. You will see it as a dependency of cmd.exe, and it is supposed to start up when Chrome does. Well, it does, but even if it's running the SA icon may not appear in the address bar for quite some time.

If you're running EMET, by the way, it's best to exclude Chrome since there are known conflicts.

McChHost ProcExp Image page.PNG

relativity
Level 7
Report Inappropriate Content
Message 8 of 20

Re: Site advisor -Not working in latest Chrome 35.0

Jump to solution

i attempted to drag the .crx file from the siteadvisor directory onto the extensions page of chrome .. Chrome said "attempting to downgrade extension"

Still the same though - does not work

Message was edited by: relativity on 6/22/14 12:53:39 PM CDT
relativity
Level 7
Report Inappropriate Content
Message 9 of 20

Re: Site advisor -Not working in latest Chrome 35.0

Jump to solution

Still works in IE and FF .. but not in Chrome

Hayton
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 10 of 20

Re: Site advisor -Not working in latest Chrome 35.0

Jump to solution

relativity wrote:

i attempted to drag the .crx file from the siteadvisor directory onto the extensions page of chrome .. Chrome said "attempting to downgrade extension"

Still the same though - does not work

No, it won't work. Chrome protects its known list of extensions from outside interference. What were trying to achieve by doing that?

And what exactly are you seeing or not seeing in the way SiteAdvisor does or does not work?

How Many Badges Can You Collect?
Ready for a little competition? Members like you are earning badges and unlocking perks for their helpful answers. Are you? Click here to find out.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community