cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
mslpplm
Former Member
Report Inappropriate Content
Message 21 of 43

Re: Re: McAfee internet security blocking McAfee siteadvisor!!

Hi PhilF.

I am also on wireless connection (windows xp).

However, trying to convert you detailed reply windows 8.1 to XP.

(Network and Sharing Center) on XP is called Internet Connection Sharing.

After that I cannot your find/convert your settings on XP, however, I am still working on it.

mslpplm
Former Member
Report Inappropriate Content
Message 22 of 43

Re: Re: McAfee internet security blocking McAfee siteadvisor!!

Catdaddy.

Tried the link. Siteadvisor.com - Is McAfee SiteAdvisor Down Right Now?

Siteadvisor.com is UP and reachable. As belowIs it down right now.jpg

mslpplm
Former Member
Report Inappropriate Content
Message 23 of 43

Re: Re: McAfee internet security blocking McAfee siteadvisor!!

Dougk_t3

When the computer is booting there is no internet connection, my computer does not automatically connect to the internet. 

(This happens only when the Windows security suite is installed; when SiteAdvisor is installed by itself the problem doesn't exist.)  Correct. This is my situation. 

Is it possible to start the computer with the internet connection enabled?  Simple answer No.  Selvan can contact myself. 

I have installed the latest version of SiteAdvisor.

PhilF
Former Member
Report Inappropriate Content
Message 24 of 43

Re: McAfee internet security blocking McAfee siteadvisor!!

In XP:

Control Panel

Network Connections

Right Click on your wireless adapter

left click Properties

left click Configure

On my Intel adapter, it would be Advanced tab, and highlight Power Management

Uncheck default and move slider to Highest (Maximum Performance)

Other wireless adapters may have a different interface, but you are looking for Power Management

.....

If that does not remedy the situation, try changing your power scheme yo Maximum Performance.

(Control Panel/Power Options)

Hayton
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 25 of 43

Re: McAfee internet security blocking McAfee siteadvisor!!

An interesting discussion, but with some confusion and a few side-issues.

Basically, DougK's answer is the correct one.

You've got XP (SP3) so you're limited to IE8 and your McAfee installation won't, at this stage, be updated beyond 12.8

The SiteAdvisor versions being quoted : 3.7.1.125 is still (just) current, but is being superseded by 3.7.1.139

The other version referred to (3.65.135.1) is the version number particular to Chrome, where SiteAdvisor will only work at all courtesy of a workaround. That version is not relevant to the main discussion, except that in the screenshots I see Chrome is the browser you're using.

The whole question of SiteAdvisor not starting correctly at system startup has been raised - and answered, to the best of my ability - in many other threads in the SiteAdvisor section. DougK knows more than I do about this but he's saying my guess about what's happening/not happening is basically correct. SiteAdvisor kicks in very early in the whole startup process and tries to talk to the servers in California. If that dialogue can't be made or doesn't complete properly then SiteAdvisor is likely to go into some sort of Wait State. On my older XP machine I can replicate this problem : the most common scenario is that SiteAdvisor will work on IE and Firefox but not, initially, on Chrome. Usually after some indeterminate period of time there is a trigger of some sort, and mcchost.exe (the Chrome SiteAdvisor process) works busily for about half a minute. After that the SiteAdvisor icon appears in the Chrome address bar, and usually (80% of the time) it works normally. Sometimes I get the icon but it stays Grey for all sites.

The key to having SA work correctly is not to disallow an internet connection at startup. In McAfee Firewall there is a setting which you need to check - under 'Smart Advice and Advanced Settings' is a checkbox, 'Block internet access at startup'. If that is checked, uncheck it - I can't remember what the default is.

If that box is unchecked and you still don't have an internet connection at startup, what is it that blocks the connection - McAfee, your ISP, you yourself? (I know some people start up with the router switched off, and only switch it on once the system is up and running, but I don't think that's necessary.) I can't work out from your reply what's causing the delay, but that delay will stop SA from making its initial connection.

If you want to see what I mean about SA kicking in early in the process just install SysInternals' TCPView and set it to run automatically at startup. You'll see every process that makes a connection, and where it's connecting to (an invaluable security precaution) and you'll see McSvHost and saupd.exe appearing very early on.

EDIT - Correction. I spoke of "startup" but I meant "Windows logon". DougK may be referring to a situation at actual system startup, but I can't be sure of that. What I see with TCPView is what happens when I log on to a particular Windows User Account, and by that stage McAfee may already be active. My own system seems to establishe an internet connection only after the login process has begun, with a variable delay before that stage completes (thanks to software installed by my ISP). We'll have to wait for clarification from DougK, if it's needed.

PhilF
Former Member
Report Inappropriate Content
Message 26 of 43

Re: McAfee internet security blocking McAfee siteadvisor!!

Sorry mslpplm, it's been a very long time since I used one of my XP machines.  I went ahead and started one up, and found that my suggested work around has no effect on XP.  While I have solved my SA issues on Win 8.1 by doing this, I believe that is due to the new fast startup feature in the newer versions of windows, where it is really never fully powered down.  Good to hear that Mcafee expects to have a permanent fix next month. 

mslpplm
Former Member
Report Inappropriate Content
Message 27 of 43

Re: Re: McAfee internet security blocking McAfee siteadvisor!!

Hi PhilF.

Again followed your good & detailed reply, In XP:

I use a laptop, although it is connect to a mains power supply.

The power management setting was set at it's default 'Lowest: Maximum battery life' setting.

I unchecked the default setting and move slider to the Highest (Maximum performance) position.

Maxium.jpg

Since moving the slider to it's 'Highest setting, and switched off the laptop and rebooted

I have noticed that after a complete shutdown and reboot, McAfee symbol is green.

I am wondering, if this problem could have been caused by a simple setting, such as power management!


I don't think of this as a work around, I think you have remedy the problem/situation not just for myself but for other people.  From Windows XP through to 8.1

Like you have previously written, I will report back in a few days time with an update.

PhilF
Former Member
Report Inappropriate Content
Message 28 of 43

Re: McAfee internet security blocking McAfee siteadvisor!!

mslpplm, glad that this worked for you.  Unfortunately, my SA is now grey again on my Win 8.1 laptop, despite my purported  fix.  Worked for a day and a half though. 

UPDATE: 9/22 got it running again. 

This time, I tweaked the wireless adapter by:

1.) re-enabling 'Allow computer to turn off this device...'

2.) under the advanced tab, disabling 'Minimum Power Consumption'

3.) in the firewall settings, keeping 'Block Internet Access at startup' unchecked

mslpplm
Former Member
Report Inappropriate Content
Message 29 of 43

Re: Re: McAfee internet security blocking McAfee siteadvisor!!

PhilF, SA worked on Saturday only back to grey on Sunday & today Monday.


Number 1) one your list; re-enabling 'Allow computer to turn off this device...' I have tried and I do not think I can do this on XP.


Number 2) under the advanced tab, disabling 'Minimum Power Consumption'.  I cannot disable it, however, I have turned the power to the Highest maximum performance.

Number 3) in the firewall settings, keeping 'Block Internet Access at startup' unchecked.  Firewall was set at it's default setting of Enable Smart Advice, Decide Automatically.  Block Internet access at startup unchecked.

SA still grey.

I'm glad you've got it running again, with all your hard work.

selvan
McAfee Retired
McAfee Retired
Report Inappropriate Content
Message 30 of 43

Re: Re: Re: McAfee internet security blocking McAfee siteadvisor!!


mslpplm wrote:




Is it possible to start the computer with the internet connection enabled?  Simple answer No.  Selvan can contact myself. 




Hi

Please follow me in Connections and Inbox Streams for sending/receiving private messages. Will be sending further instructions for a Support Session through a Private message.

How Many Badges Can You Collect?
Ready for a little competition? Members like you are earning badges and unlocking perks for their helpful answers. Are you? Click here to find out.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community