×
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
daintydinah
Former Member
Message 1 of 18

Error after Update

After running the Virtual Technician I am now getting an error message saying that a file is incorrect.... expected file not present.

c:\program files\mcafee\siteadvisor\McplgSH.dll

This has only happened after SiteAdvsor update ...... I've uninstalled/reinstalled McAfee and ran the Technician and all is fine until the update runs again.

Has anyone else found this? SiteAdvisor version is now 2.9.242
17 Replies
vinod_r2
Reliable Contributor
Reliable Contributor
Message 2 of 18

RE: Error after Update



Go to the control panel and add/remove select McAfee Security centre.
then remove siteadvisor alone to .
reboot the machine after removal

locate and delete any siteadvisor folder in program files or in
C:\Documents and Settings\All Users\Application Data
or/and
C:\Documents and Settings\All Users\Application Data/mcafee

then install Siteadvisor wait for update and check
daintydinah
Former Member
Message 3 of 18

RE: Error after Update

Thanks I'll give this a go happy
daintydinah
Former Member
Message 4 of 18

RE: Error after Update

Well the same happens again as soon as SiteAdvisor updates ...... what a load of rubbish !!!! :mad:
miandri
Contributor
Message 5 of 18

RE: Error after Update

I have exactly the same problem. Come on Mcafee sort it out. Very disappointing.
user_50483
Contributor
Message 6 of 18

We need this fixed asap!

I also get this issue. I contacted McAfee on-line chat for help. They walked me through an hour of gruelling queries about what I had and, quite frankly, if there was any way of fast-tracking the tedious queries being asked I would have PAID GOOD MONEY for it! Anyway - I am also getting this issue as reported. The file .../McAfee/SiteAdvisor/mcplgsh.dll is missing from the directory and virtual technician cannot proceed with another (probably unrelated) issue whereby my security centre status seems to switch to "Unprotected" at random. This has only occurred after a recent update. Is there any way that somebody at McAfee could provide a fix for us? Please??
lkg2116
Contributor
Message 7 of 18

siteadvisor\McPlgSH.dll not found

I get the same error as well. MCAFEE, GET ON THE BALL HERE!!

I got my software less than 30 days ago, so i called for the free support. It's more like LAKE OF SUPPORT. they are not trained techs. for a trained tech on the phone it's $10 an incident.
YoKenny
Former Member
Message 8 of 18

RE: siteadvisor\McPlgSH.dll not found

You can please some of the people some of the time but not all of the people all of the time.

I had a problem with my payment of SiteAdvisor and I contacted support and they very courteously helped me and patiently walked me getting my account information and approval implemented.

I am retired and I do not spend my limited income on frivolous things so if you are dissatisfied then by all means get something more suitable but for all its shortcomings SiteAdvisor works well for me.
exbrit
MVP
MVP
Message 9 of 18

RE: siteadvisor\McPlgSH.dll not found



Phone Technical Support is free for the 1st 30 days, at least in North America, for those who purchased software either directly from McAfee or through a retailer.

Technical Support Chat, linked via the top left of the page or in my signature is available 24/7 and has always been free, no matter when or from whom you purchased your software.

See this solved thread for a Customer who got the fix "in 5 minutes" from Technical Support Chat.
http://community.mcafee.com/showthread.php?t=227548

I suggest Technical Support Chat as your best route.
BalaSGS
Former Member
Message 10 of 18

RE: Error after Update

Hi,

Please try the following:

1.Open Internet Explorer > Click on Tools> Manage Add-ons> Enable or Disable Add-ons – Make sure all the McAfee related add-ons are enabled.
2.Run McAfee Virtual Technician from http://mvt.mcafee.com and check and see whether you are able to fix the issue
3.If the problem still persist – Uninstall only McAfee Site Advisor from the control panel> add/remove programs and reboot the computer
4.Install it back from www.siteadvisor.com and check the status.
5.If necessary uninstall Internet Explorer 7.0 from control panel> add/ remove programs, reboot the computer and try with Internet Explorer 6.0
How Many Badges Can You Collect?
Ready for a little competition? Members like you are earning badges and unlocking perks for their helpful answers. Are you? Click here to find out.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community