cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Tori
Level 7
Report Inappropriate Content
Message 1 of 2

Secure VPN

Hi all! I just bought Total Protection for 1 device, installed it on my new Surface Go laptop (turning S mode off) and got everything working, but it won't allow me to connect to the secure VPN. I get a message that I already have a device connected and I will need to remove it before I can connect on my new PC, but I literally don't have another device that would be connected and can't figure out how to find this out! Any advice or thoughts on what the issue is?

1 Reply

Re: Secure VPN

Hi @Tori 

We regret for the inconvenience!

Kindly refer the below article to troubleshoot McAfee VPN issues.

Connection issues with McAfee VPN products

Alternatively, You can always contact the chat support using below link for immediate assistance.

McAfee Support

Regards,
Sudharsanam G

How Many Badges Can You Collect?
Ready for a little competition? Members like you are earning badges and unlocking perks for their helpful answers. Are you? Click here to find out.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community