cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
nohal
Level 7
Report Inappropriate Content
Message 1 of 1

McAfee Process Validation Service (mfevtps.exe) - Stuck at starting

Hi All,

I'm not an expert in PC, so be gentle.

As per subject, McAfee Process Validation Services (mfevtps.exe) [referred in process window], is stuck at starting. Without it able to start, it prevented my other processes to run. This always happened after I've restarted my PC or after cold boot. I've found the culprit and try to stop the process, after that my whole other processes able to successfully run. But, it can't be this way the whole time. Tried reinstall, no joy. Tried McAfee Virtual Technician, the application stuck at initializing.

At one point, windows didn't allow me to stop the process. So I ran AVG scan in safemode, and I'm able to get back to the point where I can stop the process.

I can use my Internet and some application if I didn't stop mfevtps.exe process.

Video i've recorded about my problem as attached.

How Many Badges Can You Collect?
Ready for a little competition? Members like you are earning badges and unlocking perks for their helpful answers. Are you? Click here to find out.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community