cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
user101
Level 7
Report Inappropriate Content
Message 1 of 16

IE8 set as outbound and still responds to input connections

Setup  firewall as below

New Picture.png

I have set IE8 manually for Outbound only. But I keep getting the following annoying pop up all the time even if I click 'Allow Outgoing Access'.

Why can't I set It for always Outbound and not respond to incoming connections. I DONT WANT ANY INCOMING. I have had to uninstall Mcafee and install something else that always stays as outbound

New Picture (1).png

15 Replies
lixiao
Level 7
Report Inappropriate Content
Message 2 of 16

Re: IE8 set as outbound and still responds to input connections

Please try to run IE8 in safe mode and check whether you still get the warning. To run IE in safe mode, use Start menu-> All Programs-> Accessories-> System Tools-> Internet  Explorer  (no Add-ons). There could be plugin or activex on the web page that triggered Firewall warning.

Re: IE8 set as outbound and still responds to input connections

Well of course any browser requires two way "handshake" and as you it set to ask you first, it is asking, so what's the problem?

The prompt would stop if you set it to decide automatically.   I think that yoiu can trust a firewall to know what should be happening.

lixiao
Level 7
Report Inappropriate Content
Message 4 of 16

Re: IE8 set as outbound and still responds to input connections

Well when browser requests HTTP(s) content normally, it will initiate the TCP connection with server, Firewall will treat this as "outbond" and will allow server response without prompt. However if there was plugin/activex runs inside IE, they could try to accept connection request initiated by server in which case Firewall will prompt. Similar case is Firewall won't prompt FTP running in passive mode but will prompt FTP running in active mode (if auto-decision was turned off).

newjack
Level 12
Report Inappropriate Content
Message 5 of 16

Re: IE8 set as outbound and still responds to input connections

I  have not had these probems with security center 2009.As a matter of fact i have my browsers set for outbound and they work o.k. Another person is haven a similiar problem with 2010.Could this be a bug?I don`t know much about the new version. But other than what peter says as far as a handshake (& i can say peter know Mcafee)I don`t have this with 2009.

Is this version more sensitive as far as settings go?

Message was edited by: newjack on 2/13/10 10:56:52 AM CST
MRoutt
Level 9
Report Inappropriate Content
Message 6 of 16

Re: IE8 set as outbound and still responds to input connections

@OP: Looks like we have similar problems, read about mine at http://community.mcafee.com/message/114219#114219.


@lixiao: Can you provide some documentation to back up your statement that an ActiveX Plugin within IE (or an extension in Firefox) could need to accept an unsolicited connection request from a server (or elsewhere)? As I posted in my other thread, my experience has been that there is not currently a plugin that needs to accept any unsolicited (e.g. server initiated), or solicited inbound connections aside from accepting data that is in response to an outbound (solicited) connection.

Message was edited by: MRoutt on 2/13/10 1:34:38 PM CST
user101
Level 7
Report Inappropriate Content
Message 7 of 16

Re: IE8 set as outbound and still responds to input connections

New Picture.png

I started and IE8 in safe mode (no addons) and pasted the link to Mcafee help site and same problem occurs as above

I thought my router (set as NATS) may be a problem, but comes up as 100% stealth using Shields-Up test.

Re: IE8 set as outbound and still responds to input connections

I think what you originally asked for is impossible, IE just doesn't work one way only hence it will always ask cause the firewall to ask permission unless you allow it full access.  You'd be best advised to contact Technical Support Chat as they would be able to explain it in technical terms, link at top of this page, McAfee Support > Home and Home Office Support..

Message was edited by: Ex_Brit on 13/02/10 3:17:28 EST PM
MRoutt
Level 9
Report Inappropriate Content
Message 9 of 16

Re: IE8 set as outbound and still responds to input connections

Ex_Brit,


The problem, as explained both previously in this thread and in my thread is that IE (and Firefox) only need to accept data from connections already made to a server and thus do not need to accept unsolicited incoming connections.  Thus IE and Firefox only need to be set to "outbound only" in the firewall as this will allow the data to come back from a server in the course of a normal connection.  I do not understand how both the OP in this thread and me could be more clear.  Further, neither me nor the OP would have a problem if McAfee Firewall would actually implement this. 

Message was edited by: MRoutt on 2/13/10 2:30:59 PM CST
user101
Level 7
Report Inappropriate Content
Message 10 of 16

Re: IE8 set as outbound and still responds to input connections

Ex_Brit

I agree with MRoutt on how the Outbound should respond. Also the pop-up occurs after the page has been loaded. It's not like the pop-up should occur first to get your permission and then load the page. What is missing is "Do not ask again" option with "Allow outgoing access".

How Many Badges Can You Collect?
Ready for a little competition? Members like you are earning badges and unlocking perks for their helpful answers. Are you? Click here to find out.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community