Showing results for 
Show  only  | Search instead for 
Did you mean: 
Former Member
Message 1 of 7

McAfee cannot continue because JavaScript is not working on this computer


This is perhaps an old issue, and I need to find a way to resolve it.

The story goes backa couple of days when I downloaded the new version to install on my laptop, it removed the current installed version and then I started to receive this error from the setup app.

The worse part is that my IE browser does not execute any JavaScript at all anymore, I've tried registering the JScript.dll again and it did not work, upgraded the browser and re-installed some of the service packs, but the error is still there and no anti-virus or suite is being able to install.

Any thoughs on this?, :confused:


System specs: Gateway Laptop w/ 3Gb ram, Vista Ultimate OS, IE8 (at the moment).
Tags (2)
6 Replies
Former Member
Message 2 of 7

RE: McAfee cannot continue because JavaScript is not working on this computer


when you registered jscript and vbscript did you get any errors?

kindly check the list of programs in your programs and features (control panel) if java is installed....
Former Member
Message 3 of 7

RE: McAfee cannot continue because JavaScript is not working on this computer

Indeed, I did, and I got the Error Message 800405 (excuse me if it's not the correct one) dialog box.

But yes, I got an error when I ran the regsvr32.exe JScript.dll from the command line.

As for the Java itself, I remember that the icon tray was up, however to be honest I haven't checked on the Control Panel, I'l do so and keep you posted.

Thanks for the reply.!

Former Member
Message 4 of 7

RE: McAfee cannot continue because JavaScript is not working on this computer

let's try re-registering your javascrips and vbscripts... please do the following:

1. start>all programs>accessories>right click on command prompt and choose run as administrator
2. type regsvr32 jscript.dll and press enter
3. type regsvr32 vbscript.dll and press enter
4. close command prompt
5. go back to what you where doing when you encountered the java error...
Former Member
Message 5 of 7

So far So good

Thanks for the clarification, good point that I didn't ran the command line before as an Administrator, I did it and it worked. I'm at work right now and not able to hook up my laptop to the internet, but I will as soon as I get back home and let you know.

Again, thanks fo the help.

Former Member
Message 6 of 7


Just wanted to give you an update, after running the regsvr32 on Administrator mode, the installation was a breeze and all is back to normal.

I trully appreciate the quick support as this laptop contains too many developer apps so it's a pain to re-build it.



Former Member
Message 7 of 7

RE: Success!!

glad to have helped....
How Many Badges Can You Collect?
Ready for a little competition? Members like you are earning badges and unlocking perks for their helpful answers. Are you? Click here to find out.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community