Showing results for 
Show  only  | Search instead for 
Did you mean: 
Contributor II
Message 1 of 44

Inoperative Customer Support Tools

Part of the "suggested fix" for the Blank Security Center UI is to run IERegFix.bat.  Unfortunately this file contains a fatal error and will not run on Windows 7 x64.

Turning echo on for the file (Rem before the @echo off command at the start of the batch file) produces this console output:

(for brevity I have included only the output from the "Press any key to continue..." prompt onward.)





C:\>echo  Please wait for the registration process t

o complete.

Please wait for the registration process to complete.

C:\>echo  This make take several minutes.

This make take several minutes.

C:\>REM Detect IE Version here...

C:\>FOR /F "tokens=*" %A IN ('REG.EXE 2>&1 | FIND.EX

E "version"') DO FOR %B IN (%A) DO SET RegVer=%B

C:\>FOR /F "tokens=1 delims=." %A IN ('ECHO.') DO SE

T RegVer=%A

2 was unexpected at this time.

C:\>IF  GEQ 2 (



It has been too long since I've done batch scripting (i.e. MS DOS 3, before Windows ever saw the light of day) so it would take a really long time for me to get my command line head on again and fix this.  Perhaps someone at McAfee who is immersed in this stuff daily could fix this ASAP.

43 Replies
Reliable Contributor
Reliable Contributor
Message 2 of 44

Re: Inoperative Customer Support Tools

I was going to point you towards that document but you got there first.

The doc is a year old so yes, it may need amending, or updating for Windows 7. Like you my DOS batch scripting is a little rusty but the problem appears to be with "REG.EXE 2".

This came from Jayadeep NR so I've sent him a message to have a look at the output and try and figure out what needs changing.

Message was edited by: Hayton - message sent to Jayadeep -  on 27/05/12 05:40:40 IST
Contributor II
Message 3 of 44

Re: Inoperative Customer Support Tools


My McAfee Internet Security was running fine until about 10 days ago when the UI disappeared. So,

  1. I did all the steps at the above referenced doc, with the exception of IREGFix.bat which wouldn't run,
  2. Ran MVT, it found two minor reg problems and one McAfee dll that needed updating (which is weird since I am set to auto update).

This didn't fix the problem. 

So next (with full reboots between each step) I

  1. Uninstalled all McAfee products with Windows uninstall program
  2. Ran the McAfee complete uninstall tool
  3. Ran tge Microsoft Baseline Security Analyzer tool, and fixed the minor problems identified (no security audit logs enabled)
  4. Ran McAfee Pre-install tool
  5. Ran MVT again
  6. Installed McAfee Internet Security from fresh download from my account

This made the  problem worse.  Before I had the interface with checkmarks but no text for the various "home page" options.  Now, I don't even have the checkmarks, just the pull-down bars.McAfee Screen Capture.JPG

I've also run McAfee Mer tool and uploaded it to the SR# for the original go-around I had with this problem late last year.

Then I ran McAfee trace tool, opened security center, saved the log file and have it ready to go to McAfee.

However, I feel all this logging will be a complete waste of time because McAfee does not let users with recurrent problems communicate with software engineers who might have access to source and object code listings, and be able to make sense of all these logs.  The customer support people are tasked with getting you out of the forums, off the phone, out of sight and out of McAfee's hair ASAP, and not with actually solving the problem.  So all their scripts are designed to make you go through all these unguided trial-and-error workarounds, or total system reinstall from scratch to maybe fix a problem which might require one simple registry key update if a software engineer was actually tasked with looking into the problem and step-by-step working through the program logic with all the available logs and data at hand.

Message 4 of 44

Re: Inoperative Customer Support Tools

Your thread regarding the blank UI is here:  https://community.mcafee.com/message/241562#241562

Which thread should we continue with Hayton?  There should only be one.

Message was edited by: Ex_Brit on 27/05/12 6:28:41 EDT AM
Message 5 of 44

Re: Inoperative Customer Support Tools

What's all this about echo?    You simply right-click the saved ieregfix file and run as Administrator and it should present a window saying press any key to continue.  Do that and it's over in a flash.  All it does is set IE to its default settings which SecurityCenter relies upon to function, because it actually is an IE webpage, albeit internal.   I just tried it in Windows 7 Ultimate SP1 x64 w/IE9 as default browser and no issues.

Are you by any chance using the 64-bit IE as your default?  If you are you shouldn't as few add-ons are working for it.  Microsoft recommends people use the 32-bit one for now.   They are both listed in Start/All Programs and as they are lumped togather it's easy to pick the wrong one.

Also have you imported any fonts lately or changed fonts?   The bottom of that link you posted mentions that those can cause issues.

Message was edited by: Ex_Brit on 27/05/12 7:26:32 EDT AM
Contributor II
Message 6 of 44

Re: Inoperative Customer Support Tools

Come on, Ex-Brit - get with it!

Simply executing the file leads to an error instead of the documented steps to successfull completion.  Look at the output "2 was unexpected at this time" and the fact that enabling command echo proves the file errors out and exits before completion of the first IF statement in the file - i.e. before it actually does anything at all!  And if you actually looked at the console output on your system, you would also see that it is not working correctly.

64 bit IE is not the default.  Whether 32-bit IE or Firefox is default browser, no difference in script or security center UI look.

Finally it was working fine after my Nov / Dec uninstall of the entire OS, reformat of HD and dual-clean reinstall procedure as documented in the thread you cut off.  The UI disappeared after a nearly daily flurry of McAfee new version install notices from the McAfee auto update routines during the last 10 days.

RE fonts, I have not manually installed new fonts (and even if I did, that is a sorry excuse for McAfee and would still be a bug in their software that THEY SHOULD FIX).  But over the time since it was working I have installed apps that install fonts (MathCad, Adober Master Collection CS6 etc.).  So if McAfee cannot tolerate additions to the font catalog, then you are saying that once McAfee is installed and working correctly NO OTHER APPS CAN BE INSTALLED OR IT IS THE USERS' FAULT THAT MCAFEE STOPS WORKING?!?!  That is totally assinine.  It would almost point to a very dumb coding error like using an index into the system font list based on an installation with ONLY fonts from the OS disk, rather than actually using the font name, and looking for that font name every time the OS is booted.

If you look at the number of threads / posts / views related to this topic you cannot help but see that this is not an "only one user" problem.  You can further see that it requires direct access to a McAfee software engineer - not a customer support weenie - who can look at the source / object listings, user logs from MVT, MER, McTrace, etc., pin-point the problem code in the updates, and fix it.  It probably would take an engineer familiar with the source in the affected module less than 1/2 a day to fix. But it appears McAfee has no desire to do so.

Message 7 of 44

Re: Inoperative Customer Support Tools

I am with it, just trying to help and was only wondering why you would get such a result when none of us do.    That regfix has been around since the Earth cooled and has never caused that result as far as I recall.   The fonts idea was just one of many suggestions that MAY be a cause that's all.

I suggest you open a case with Technical Support - it's free by phone or online chat and linked under Useful Links at the top of this page.

I assure you this is not normal and is a mystery to us why every now and again people report this blank interface issue and we can never reproduce it.

Technicians can connect with your machine to troubleshoot the issue.

Message was edited by: Ex_Brit on 27/05/12 8:19:19 EDT AM
Former Member
Message 8 of 44

Re: Inoperative Customer Support Tools

Hi wmcole and Hayton,

The scrpipt file working properly on Windos 7 and IE 9 ( I assume you have IE 9 ) eventhough It was last updated on May, 2007. Anyway wmcole, did you try to run that bat file by giving administrative previllage, if not try to right click on the batch file and select "Run as Administrator". There may be some issues with IE settings or DLL files related to IE. McAfee using Internet Explorer platform and that's why we suggest running IEregFix.bat file. In most cases this issue has been resolved by roll back to IE 8 .

Did you try to run IEregFix.bat file after the complete Wipout and re-installtion of OS and le t me know? Also can you please share the case number if you contacted our technical support?

on 28/5/12 11:57:36 PM IST
Contributor II
Message 9 of 44

Re: Inoperative Customer Support Tools

IERegFix.bat does not, and never has run successfully on this machine whetner run as admin from icon or run from a run as admin command shell.  It always fails and exits between the secont FOR statement and first IF statement with message "2 was unexpected"





REM Detect IE Version here...

FOR /F "tokens=*" %%A IN ('REG.EXE 2^>^&1 ^| FIND.EXE "version"') DO FOR %%B IN (%%A) DO SET RegVer=%%B

FOR /F "tokens=1 delims=." %%A IN ('ECHO.%RegVer%') DO SET RegVer=%%A

>>>>>>FAILS AND EXITS HERE<<<<<<<<<<<<<<<<<<<

IF %RegVer% GEQ 2 (

    FOR /F "tokens=2*" %%A IN ('REG.EXE QUERY "HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Version Vector" /V "IE" ^| FIND "REG_SZ"') DO SET IEVer=%%B

) ELSE (

    FOR /F "tokens=1*" %%A IN ('REG.EXE QUERY "HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Version Vector\IE" ^| FIND "REG_SZ"') DO FOR %%C IN (%%B) DO SET IEVer=%%C


rem %IEVer%




However, I suspect, based on the log output, that MCPreInstall.exe attempts to register the same set of .dlls, and it runs to conclusion flagging no particular errors.  MVT finds no errors.  MER and MCTrace provided numerous log files, but they need a software engineer with access to souce listings to interpret.

And I am NOT going to go through down-time and mult-day process of wiping / reinstalling the OS just to get McAfee to work right.  I will be switching to another security suite which works without this problem re-curring every two - three months since McAfee is apparently, after severl years of this problem, unwilling to fix it, but rather laying it all at the feet of their users to fix / work around every time one of their auto updates re-instates the problem.

Former Member
Message 10 of 44

Re: Inoperative Customer Support Tools

I understand that, I will check about IERegFix tool and let you know the status. Also please let me know the cipher strength of IE installed on your computer?

in the mean time could you able to revert back to IE 8 version and check the issue with McAfee?

on 29/5/12 3:46:12 AM IST
How Many Badges Can You Collect?
Ready for a little competition? Members like you are earning badges and unlocking perks for their helpful answers. Are you? Click here to find out.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community