cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
lixiao
Level 7
Report Inappropriate Content
Message 1 of 19

Steps to fix Firewall OFF issue

If you are having issue of Firewall keeps off and cannot be turned on, please try following steps:

  1. Double click on McAfee icon on desktop or in system tray;
  2. Click "Navigation" on top-right, click "General Settings and Alerts" under Settings, click "Access Protection", uncheck "Use Access Protection", click "Apply" button.
  3. Press <WIN>+<R>, type "regedit.exe", press <ENTER>. If Windows prompts whether to run the program, answer "Yes".
  4. In Registry Editor, navigate to key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\McMPFSvc, double click on "Start" on the right, change its value to 2, click "OK" button.
  5. In Registry Editor, if there is a sub-key named "Security" under key "McMPFSvc", right click on it and select "Delete" from menu. Warning: please make sure right click on "Security", not "McMPFSvc".
  6. Close Registry Editor, re-enable Access Protection by reverting what has been done in step 2, reboot machine.
  7. After reboot, open McAfee Security Center, click "Navigation", then "Firewall" to make sure Firewall is now ON.

If Firewall shows "ON" in step 7, the issue has been fixed. If it stays "OFF", please continue following steps:

  1. Click "Navigation" on top-right, click "General Settings and Alerts" under Settings, click "Access Protection", uncheck "Use Access Protection", click "Apply" button.
  2. Search "Command Prompt" in start menu, right click on it and select "Run as administrator", answer "Yes" to run command prompt.
  3. In command prompt, type regsvr32 /s "%ProgramFiles%\McAfee\MPF\MPFSvc.dll" and press ENTER.
  4. In command prompt, type regsvr32 /s "%ProgramFiles%\McAfee\MPF\MPFAPI.dll" and press ENTER.
  5. In command prompt, type regsvr32 /s "%ProgramFiles%\McAfee\MPF\MPFEvt.dll" and press ENTER.
  6. In command prompt, type regsvr32 /s "%ProgramFiles%\McAfee\MPF\MPFAPIPS.dll" and press ENTER.
  7. In command prompt, type regsvr32 /s "%ProgramFiles%\McAfee\MPF\MPFSvcPS.dll" and press ENTER.
  8. In command prompt, type regsvr32 /s "%ProgramFiles%\McAfee\MPF\MPFShm.dll" and press ENTER.
  9. Re-enable Access Protection by reverting what has been done in step 1, reboot machine.
  10. After reboot, open McAfee Security Center, click "Navigation", then "Firewall" to make sure Firewall is now ON.

If Firewall stays off even after these steps, please perform an uninstall and re-install. It is also recommended to run McAfee Cleanup Tool before re-install to make sure a clean install will be performed.

We for the inconvience caused by the issue. We are currently investigating it and will put migration methods into next release as well as McAfee Virtual Technician.

on 3/21/13 6:21:51 PM EDT
18 Replies
karthiks
Level 12
Report Inappropriate Content
Message 2 of 19

Re: Steps to fix Firewall OFF issue

lixiao,

Thanks for posting your suggestion, it’s  good to try these steps

SafeBoot
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 3 of 19

Re: Steps to fix Firewall OFF issue

you can use the command line

for %1 in ("%programfiles%\mcafee\mpf\*.dll") do regsvr32 /s "%1"

or

for %1 in ("%programfiles(x86)%\mcafee\mpf\*.dll") do regsvr32 /s "%1"

if you're using a 64bit OS (I think!)

instead of typing each of those lines separately - its a lot easier

dba-g
Level 7
Report Inappropriate Content
Message 4 of 19

Re: Steps to fix Firewall OFF issue

The suggestions here didn't fix the problem for me. I found the following on Microsoft.com which took care of the issue immediately:

Cause

This may be caused because the “NT Service\MpsSvc” account does not have adequate permissions on the following registry key

HKLM\SYSTEM\CurrentControlSet\Services\SharedAccess

Solution

  1. In Registry Editor, browse to the key HKLM\SYSTEM\CurrentControlSet\Services\SharedAccess
  2. Right click SharedAccess, and click Permissions.
  3. Click Add.
  4. In the “Enter the object names to select” field, type “NT SERVICE\mpssvc”. Then click Check Names. The name should change to MpsSvc
  5. Click OK.
  6. Select Full Control in the Allow column.
  7. Click OK.

Applies To

Windows 7 (all versions) / Windows Vista (all versions)

vinod_r2
Level 11
Report Inappropriate Content
Message 5 of 19

Re: Steps to fix Firewall OFF issue

Re: Steps to fix Firewall OFF issue

I'm having the same issue for couple of days now. didn't do anything before this firewall thing happen. I followed the suggested steps here but still the firewall is turning itself off.  I tried starting the service MPSSVC using the administrative services but i'm getting "error 1068: The dependency or group failed to start."

What's going on again McAfee???

Re: Steps to fix Firewall OFF issue

delacroix
Level 7
Report Inappropriate Content
Message 8 of 19

Re: Steps to fix Firewall OFF issue

  1. In Registry Editor, navigate to key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\McMPFSvc, double click on "Start" on the right, change its value to 2, click "OK" button.

did you mean "StartOrder" on the "Start" ???

is it compatible with Windows 8 pre-installed ??

by the way I'm using Dell Inspiron 3521 Windows 8 Pre-installed 64bit

Thank You

Message was edited by: delacroix on 6/10/13 12:22:44 PM CDT
scadutof
Level 7
Report Inappropriate Content
Message 9 of 19

Re: Steps to fix Firewall OFF issue

I have used this above fix twice from lixiao whose orignal comments above started this thread.  His / her solution works.  It fixed my random toggling of my McAfee firewall from going from on to off.   

Re: Steps to fix Firewall OFF issue

Hi All,

In my case, just following the steps 1 to 7 of the first post on https://community.mcafee.com/message/280363, seemed to sort it out, but I have just had to apply the fix a second time to the same PC after a couple of months without my other half reporting a problem, but it may have gone un-noticed for a while...

I urge you to check whether McAfee is faithfully reporting the status of the Firewall. 

I recommend using a better check (e.g using the Start - Run - services.msc to confirm the McAfee Personal Firewall Service has been started again) rather than simply looking at the McAfee window, because on my PC, prior to fixing the problem, McAfee was reporting that the Firewall was On, but the services.msc disagreed with it, reporting it was Disabled.  Within McAfee, I found I could reach the point where I had the button permitting me to turn it Off (with all McAfee indications up to that point saying it was On), but the services.msc saying it was Disabled.  Only after some time reporting "On" (perhaps about 15 to 20 minutes after switching on the PC) does McAfee decide that in fact it is Off.  At that point, the red warning banner appears, and the "On" button is availabe but ineffective.

In my case the simple remedy seems to have been effective, since I applied it on 7th June, but it recently failed again in the same manner, and I have employed the same fix again.  As before, this has been done without the "fixit" but has only been applied this evening, and only for the single reboot required by the process. 

Win XP SP3, and no Base Filtering Engine required.

Andy

How Many Badges Can You Collect?
Ready for a little competition? Members like you are earning badges and unlocking perks for their helpful answers. Are you? Click here to find out.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community