Showing results for 
Show  only  | Search instead for 
Did you mean: 
Message 1 of 6

McAfee Security from Bell Update Fail

Update keeps failing. I have tried: 

1. Check any firewall apps is installed from "Applications"? If any installed, please remove them and try McAfee update

2. Clear cache and cookies from safari (It will not remove your browsing history or saved passwords in Safari)

     Open Safari

     Click on "Safari" from Menu bar and choose "Preferences"

     Click on "Privacy" tab

     Click on the button "Remove All Website Data"

     Click on the button "Remove now" or "Remove all"

3. Change McAfee Firewall type to Home or wok

4. Initiate McAfee updates and check the status

None of these options have worked.


Below are my system specs and the version of McAfee I am running:

Screen Shot 2018-12-07 at 1.33.12 AM.png

Screen Shot 2018-12-07 at 1.27.12 AM.pngScreen Shot 2018-12-07 at 1.27.24 AM.png

5 Replies
McAfee Retired
McAfee Retired
Message 2 of 6

Re: McAfee Security from Bell Update Fail

Hi @Bvalderrama,

We are sorry for the inconvenience caused with McAfee Software update on your Mac. We have sent a private message to you. Kindly reply to that.



Message 3 of 6

Re: McAfee Security from Bell Update Fail

Hi,  I am having the same problem.  Can you send me directions on how to fix this?

McAfee Retired
McAfee Retired
Message 4 of 6

Re: McAfee Security from Bell Update Fail

Hi @Renee1,

I sent you a private message, please check and reply back for assistance.


Message 5 of 6

Re: McAfee Security from Bell Update Fail

Hi there!

I'm also with Bell, a Mac user (Big Sur version 11.4), and just started using this McAfee product last night but am experiencing the exact same issue. Are there any solutions to this updating issue? It says that it can't install a downloaded engine when I look at the update error message.

I ran the diagnosis tool and I got this line as well:

Successfully Generated diagnostic report for StatefulFirewall.. 
uudecode: [...]/StatefulFirewall/bin/StatefullFirewallMertool.sh: missing or bad "begin" line

Message 6 of 6

Re: McAfee Security from Bell Update Fail

I'm having the same problem. could you please send me instructions on how to fix? Thank you.

How Many Badges Can You Collect?
Ready for a little competition? Members like you are earning badges and unlocking perks for their helpful answers. Are you? Click here to find out.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community