Showing results for 
Show  only  | Search instead for 
Did you mean: 
Report Inappropriate Content
Message 1 of 3

Can't reinstall McAfee, and getting errors with all McAfee tools

My original issue started with getting a script error in Google Chrome. I was advised to uninstall my 'McAfee 3 device internet security' to see if that was the problem. It was. I had uninstalled using add/remove. I contacted chat on assistance in reinstalling. Agent said I needed to upgrade my internet service before he could assist me further since it took a bit of time to download the tools. I'm trying to do this myself now because I don't know when I can upgrade.

Starting with trying to install my anti-virus: It gets all the way to 'System check" box. Before it gets to 'software check" I get the message "Something went wrong with the installation". I tried installing again. Still won't work. The other option it gave was 'Run McAfee virtual technician" code 12152.

Next, I choose to 'run McAfee Virtual tech. I installed the McAfeee Software Install Helper". I make it to the "Prepare your computer to install your McAfee software. Please wait..this may take around 10 minutes". At first I got error messages, but now all it does is restart itself, causing me to go through the same steps on install helper.

After that I tried installing the MCPR tool. The chat agent had downloaded it, but it was at that point he suggested upgrading and that he'd assist afterwards because he had difficulty continuing the tool. I get the error message "Could not start process as Admin" when I tried running the MCPR tool myself.

I saw there was some kind of McAfee pre-install tool. I tried downloading that, but the page wouldn't open. Recently I tried contacting help through chat so they could send my instructions on what to do, and my information won't go through. It acts like I'm not giving it a valid phone number, and I am!

So none of the McAfee tools are working to help me install my product again. I was signed in on the admin account on my computer when trying all of this. I've run cleaners to clear cache. I tried downloading the tools from Firefox and Google Chrome  and Internet explorer (the only browsers I have) Can't get into chat. I need to know what I can do to get the tools to work and get the anti-virus reinstalled.


2 Replies

Re: Can't reinstall McAfee, and getting errors with all McAfee tools

Hi @Blkwolf20 

We regret for the inconvenience!

These errors indicate general network problems. These problems can cause your product download to disconnect or fail. Kindly refer the below article to trubleshoot the McAfee installation issues.

How to troubleshoot McAfee download or installation issues

Alternatively, You can always contact the chat support using below link for technical assistance.

McAfee Support

Sudharsanam G

Report Inappropriate Content
Message 3 of 3

Re: Can't reinstall McAfee, and getting errors with all McAfee tools

I've tried those steps. I'd like to contact support if I can get a different person to help me. I've gotten the same person twice and we didn't get anywhere. This isn't linked to an internet issue. 

How Many Badges Can You Collect?
Ready for a little competition? Members like you are earning badges and unlocking perks for their helpful answers. Are you? Click here to find out.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community