Showing results for 
Show  only  | Search instead for 
Did you mean: 
Former Member
Report Inappropriate Content
Message 1 of 7

Firewall Problem

Hello. I need little help

Few days ago I  instaled McAfee Total Protection and made this :'' Firewall - Settings - Smart Advise and Advanced Settings   -  Ask me to decide '' !!!

Certainly when I start up any application, eg. Google earth, Mcafee firewall will show the notification will you allowed or block it, and i will decide what i going to do... ?   This is eveything OK. It works well.

But today, I must Formating PC and I ' ve installed McAfee again, I repeat it all procedure above , firewall doesn't work as I described.

It won't send me notification '' Block or Allowed Programs''  What I going to do ?

I tried  to be  short and clear with question .

Thank you

6 Replies
Valued Contributor II
Report Inappropriate Content
Message 2 of 7

Re: Firewall Problem

Did you know McAfee has a special removal tool that is recommended to be used if you are uninstalling and reinstalling the software? Your post did not indicate that you used it.

I would recommend you uninstall the software under Add/Remove programs and reboot the computer. Open up your browser and go to Useful Links at the top of this page and run the MCPR removal tool. MCPR will remove any traces of McAfee that the normal uninstall might have missed. Reboot the computer again and login to your online McAfee account and download your software.

This should get your issue resolved.

Former Member
Report Inappropriate Content
Message 3 of 7

Re: Firewall Problem

Thank you. I haven't expected your answer so fast.

First of all I didn't  mentioned I use McAfee T.P. 2010. not 2009.

I mad mistake with post and topic.! Sorry

Ok. I will download remove tool, and will do as you recomend. And Try Install again.

I'm going to contact you if i would have some probl.again.

I hope that is real thing.

Former Member
Report Inappropriate Content
Message 4 of 7

Re: Firewall Problem

It's same problem !!!!

1. I removed mcafee in ''add-remove'' and restart pc.

2. I downloaded ''removal tool'' as you've recommend and ran it  and restart.

3. I downloaded mcafee from my account and installed it again

4. I opened firewall settings and put '' ask me to decide''

5. There's NO notification of firewall when tried access on internet any aplication, eg. google earth, mozilla firefox ,etc. Everything works as default without my permission.

Coul you give me a advice  what and how i have to do to fix that problem ? If it possible ?

I'm thinking about install other  firewall isoftware.

thank you

Re: Firewall Problem

Went you elected ask me to decide did you apply the choice?

Go to the security settings of the firewall and set it on monitored. May not make the fix but I feel it is a better setting.

Finally if no chop download and run  MVT the virtual technician from the technical services page. Go to useful links above and select tech services.

Former Member
Report Inappropriate Content
Message 6 of 7

Re: Firewall Problem


Finally, firewall works well, problem resolved.

When i had been uninstalled wind.. and set up again. everything is diferent !!!

It must be an ERROR  in os windows.

thanks guys, enyoj

Re: Firewall Problem

Marked as assumed answered

How Many Badges Can You Collect?
Ready for a little competition? Members like you are earning badges and unlocking perks for their helpful answers. Are you? Click here to find out.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community