Showing results for 
Show  only  | Search instead for 
Did you mean: 
Message 1 of 9

Cannot access via remote desktop after an update.

I have Windows XP professional and remote desktop enabled. I have McAfee Antivirus Plus version that recently updated and now I cannot access my computer remotely. I have disabled the firewall and it did not help. I have checked everything else and I know it has to do with Mc

Aafee program and I don't know what else to do. Thanks for any help.

8 Replies
Valued Contributor II
Message 2 of 9

Re: Cannot access via remote desktop after an update.

You may want to uninstall via Add/Remove programs and reboot, then run the MCPR removal tool found under Useful Links at the top of this page and reboot again. Login to your McAfee account and download your software. See if that fixes your issue. If it doesn't then I would suggest you contact Technical Support Chat also found under Useful Links.

One other suggestion before you consider the above, is to run the McAfee Virtual Technician. This tool examines the McAfee files installed on your computer and attempts to fix anything it identifies that relates to McAfee.

Message 3 of 9

Re: Cannot access via remote desktop after an update.

The virtual Technician is available under the technical services link in the useful links tab at the top of this page. FYI

When you uninstall check your remote access before reinstalling.

Message 4 of 9

Re: Cannot access via remote desktop after an update.

Thank you both for your responses. I followed all the instructions/steps. Virtual Tech. and then the program has been removed. I received message that removal is successfull. I still cannot access via Remote desktop. I have checked all the settings and re-did the port forwarding even though they were in place. Removed Windows Firewall. I tried the chatline and received service number but when I pressed chat it opens up a second window to close it again. Tried several times.  I have been using Remote Desktop for years without any problems until this update of McAfee. I would appreciate any help in this matter. (I did not reload McAfee) I cannot even access from a computer in the same network. Thanks.

I get this message when the CHAT window closes.

Windows Data Execution Prevention detected an add-on trying to use system memory  incorrectly. This can be caused by a malfunction or a malicious add-on.

Message was edited by: kn2000 on 5/5/10 2:21:39 PM CDT
Message 5 of 9

Re: Cannot access via remote desktop after an update.

Asked our tech for comment

Message 6 of 9

Re: Cannot access via remote desktop after an update.

He emailed me the following

Sounds  like 2 separate issues are happening. 

1)    Remote  Desktop is (possibly) being blocked.  RDP (mstsc.exe) uses TCP port 3389 to  connect.  Outbound from the computer this should work fine without any changes.   But if ‘he’ wants to allow someone else to connect using the RDP protocol, he  needs to allow it inbound in System Services.  Without 2010 installed, he’d need  to make this same change in his Windows Firewall.

2)    DEP is  having problems with (blocking) the Chat app.  ‘He’ needs to double-check his  DEP settings (under System Properties, Advanced).  Another possible alternative,  is that this could be a memory addressing issue, which we can’t do anything  about; could be hardware, but more likely an OS issue.

Hope this helps if you want more info re Data Execution Prevention ( DEP) I have pics he sent that I can email you. It is in system properties/advanced/ performance

Message was edited by: Peacekeeper on 6/05/10 11:19:26 AM
Message 7 of 9

Re: Cannot access via remote desktop after an update.

Thank you again. Windows Firewall was already disabled. I finally did System Restore to the date before the McAfee update and it worked. I never did get thru the chatline. I gave up on that. Thanks for your help.

Message 8 of 9

Re: Cannot access via remote desktop after an update.

THanks for the update glad that worked as I do not know Rd well enough.

Former Member
Message 9 of 9

Re: Cannot access via remote desktop after an update.


I have the same problem: I cannot get the remote desktop connection program to log in with a VPN that is properly set up. I have windows XP pro and McAfee security center 2010. I read the comment but I don't understand what I should do now to solve this problem. I opened the 3389 port both in Windows Firewall and McAfee firewall. I even tried it with disabling either or both firewalls completely but still I can not connect to the remote desktop. All help is very welcome, thanks!

How Many Badges Can You Collect?
Ready for a little competition? Members like you are earning badges and unlocking perks for their helpful answers. Are you? Click here to find out.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community