cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
steveuk
Level 7
Report Inappropriate Content
Message 291 of 365

Re: McAfee Service Host Problem

I had the same problem. (Host error message and internet disconnections). I downloaded, installed and ran McAfee Virtual Technician and it seems to have cured the problem. You can get it here http://service.mcafee.com/TechSupportHome.aspx?lc=2057&sg=TS

ajinaz
Level 7
Report Inappropriate Content
Message 292 of 365

Re: McAfee Service Host Problem

Installed McAfee and..

      I have the same problem along with the inverted or reversed IP. The My Network claims it found a new network and has a Trust button. Have Mcafee on another Win 7 machine (which appears to running ok after working over the firewall rules for my systems) , and various devices on my net.  My Network in Mcafee shows my ip wrong and seems to think my network is xxx.xxx.168.192.    Of course at random but usually when running Firefox (the latest version) McSvHost.exe will crash. I get the "your computer is at risk" then the module restarts itself and the network comes back and so on...

XP sp3  3.2gb Ram (4gb installed)  Dell Optiplex 745.  

5-User Cox Security Suite Plus 15.0.300

Linksys Wireless

App Log

I get the "Faulting application McSvHost.exe, version 2.0.230.0, faulting module unknown, version 0.0.0.0, fault address 0x0a715db0."

Event ID: 1004

System Log

Process **\MCSHIELD.EXE pid (428) contained unsigned or corrupted code and was blocked from performing a privileged operation with a McAfee driver.

1. Ran The MVT it fixed 1 registry error and said the .dat was corrupt. 

2. Ran the SuperDat. The log says...

   Error: Product already running latest engine files.

   Update process completed successfully.

3. Unistalled McAfee. Cleaned up the unistall with the tool.

4. Installed TrendMicro. It found 40 items mostly cookies. Ran that for a couple of days no problems..

5. UnInstalled TrendMicro.

6. read all of the above again but this time when you get to 3 on my list skip to 7.

7

Message was edited by: ajinaz on 5/23/12 1:55:46 PM CDT

Re: McAfee Service Host Problem

The issue is usually only on XP and  a fix is in a patch waiting clearance by QA. It is being held up now due to a recent bug missed in the latest release.

Have you tried disabling Netguard? This is a firewall feature. That usually works.

Rather than the superdat run the xdat version that has no engine in it.

richenone
Level 7
Report Inappropriate Content
Message 294 of 365

Re: McAfee Service Host Problem

Dear Moderator,

I did not see any reference to the "McAfee Service Host Problem" pop up on the net issue url you put on this posting. It just talks about the disconnect issue. How are they one and the same?

How close is the resolution as I have also dealt with this for months and it means all my disk backups have this problem?

Thank you,

Rich

Re: McAfee Service Host Problem

No not the same the Mcsvhost issue fix  is very soon to be released the net issue just follow the FAQ I posted there and a fix will come in the near future

chappers
Level 7
Report Inappropriate Content
Message 296 of 365

Re: McAfee Service Host Problem

I am positively furious about this now.

WHEN are McAfee going to commit to an actual release date for this fix - "in the near future" is NOT ACCEPTABLE...this has been going on for far too long.

The impact on my business cannot be underestimated - up to 6 times per day, my internet browser crashes, causing knock on impacts with other pieces of software I am running, and me wasting my time restarting the browser or rebooting the whole PC.

If I wasn't getting this as part of a BT Broadband package, rest assured I would have cancelled months ago and made a claim for monies spent due to lack of service provided.

I don't think it's too much to ask for McAfee to provide a piece of software which works and doesn't cause endless disruption to its customers.

JUST SORT IT OUT NOW!

Re: McAfee Service Host Problem

Well, as the OP of this post and as the person who first brought this problem to light I can honestly say that for the last month or so I have been without McAfee and now no longer have problems. I waited far too long and simply got fed up waiting. So, now I just read the comments as they come in.

rangertim
Level 7
Report Inappropriate Content
Message 298 of 365

Re: McAfee Service Host Problem

I confess I have not read all 30 pages in this thread.  I apologize for redundancy with any earlier posts.  McAfee has wasted a great deal of my time.  I also have this McAfee service host error issue--on three computers running xp. 

Disabling SiteAdvisor fixed the problem for a while.  Running Virtual Technician always fixes the problem, whether or not Virtual Technician acknowledges finding any problems.  Withing 20 minutes or so, though, the service host crashes again.  Per McAfee Knowledge Base instructions I uninstalled Total Protection using both Windows and McAfee Removal Tool then downloaded and reinstalled.  The problem persists.  I ran a complete scan--no problems found. 

Yesterday I chatted with a technician.  He took control of my computer, running ieregfix.bat, runme.bat, and McPreInstall.exe.  I'm sure he did some other things.  The problem persists.

My point is this.  If this McAfee Service Host crash is a known issue waiting on a patch as Peacekeeper stated in Post 294 ["The issue is usually only on XP and  a fix is in a patch waiting clearance by QA. It is being held up now due to a recent bug missed in the latest release."], why did the technician waste my time and his on a fix that would not work?

Message was edited by: rangertim for typo on 5/26/12 10:56:41 AM CDT

Re: McAfee Service Host Problem

Cara I am not allowed to release it the last release date was stopped as a bug was found. the last time we mods released a date the patch was held up for a month so do not want that angst again. Believe me it is very soon.

The problem is you have a version supplied by Mcafee to BT. BT may require ,as do other partners, their own QA testing this would hold things up so I will check for you.

Ranger re tech wasting time sometimes info does not filter down to the front line techs . Will pass this onto their supervisors. Do you have a SR/job  number?

Message was edited by: Peacekeeper on 27/05/12 8:14:32 AM
rangertim
Level 7
Report Inappropriate Content
Message 300 of 365

Re: McAfee Service Host Problem

Thanks for passing this on, Peacekeeper.  Perhaps the techs will get the word so other users will be told to be patient until the patch has been debugged.  I do not have an incident number but I do have the tech's name if that helps.  If you send me an email I'll sent you the name.

How Many Badges Can You Collect?
Ready for a little competition? Members like you are earning badges and unlocking perks for their helpful answers. Are you? Click here to find out.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community